Author Topic: IMS Pro TWO Issues  (Read 7222 times)

picpile.net

  • Newbie
  • *
  • Posts: 2
    • View Profile
    • Email
IMS Pro TWO Issues
« on: May 06, 2010, 10:35:55 am »
Hello TK.org. I was told to come here from Alex Benzer of Webligo for support.

Issue #1:
I'm using IMS Pro for my website, picpile.net. I've had a few users complain about file size for uploads. They're saying 1mb is not sufficient. I'd like to have the option to add 2 and 3 mb uploads.

I have limited php knowledge, enough to make little scripts but IMS Pro is too convoluted for me.

Going through upload_images.php, I'm seeing:

Code: [Select]
if($file1 != "none") {
   $size = $_FILES['file1']['size'] / 3072;
   $size = round($size, 0);
   if($size > $user_info[max_filesize]) {
   $badfiletrue = "yes";
   $exceedmax1 = "yes";
   $badfile1 = "yes";
   if(isset($reasons1)) {$reasons1 .= ", "; }
   $reasons1 .= "file size too large";
   }}

As you can see, I changed
Code: [Select]
   $size = $_FILES['file1']['size'] / 3072; to say 3072 (3mb)

However, this is not working. I'm still limited to 1mb.

Issue #2:
Despite uploading a file thats obviously too large. I'm not getting the error of $reasons1. The .php file is returning "Only images of the following types are accepted: jpg, jpeg, gif, bmp, png, pdf." even though the image uploaded is a .jpg. Obviously thats an issue.


I have had some users email me saying their file is under 1mb, of a proper file extension and yet IMS Pro is still saying its an invalid file type.

Please Help

TurnKey Admin

  • Administrator
  • *****
  • Posts: 63
    • View Profile
Re: IMS Pro TWO Issues
« Reply #1 on: May 06, 2010, 10:38:33 am »
1 and 2 are php related settings.

Increasing Upload Limits PHP

By default php sets the max upload filesize to 2mb
To view your current php settings create the following file
Code: [Select]
<?php
phpinfo
();
?>

Save it as info.php and upload to your website then view it in your browser.

The two important variables are
upload_max_filesize
And
post_max_size


Next step is to change those settings. Look for "Configuration File (php.ini) Path " and
"Loaded Configuration File" on the phpinfo page to find your php settings are stored.

Edit that file and increase upload_max_filesize and post_max_size to the size of the largest file you wish to be allowed uploaded.

Then after your save those changes be sure to restart your webserver for the changes to take affect.






picpile.net

  • Newbie
  • *
  • Posts: 2
    • View Profile
    • Email
Re: IMS Pro TWO Issues
« Reply #2 on: May 06, 2010, 10:46:32 am »
I appreciate the quick response. So you're saying what I've altered to IMS Pro is correct and should work? I tried to upload a file that 1.7mb (under the 2mb set by php http://www.picpile.net/info.php) yet IMS Pro still refuses to accept the file.

I'm seeing upload_max_filesize 2M and post_max_size 8M

I might be the largest service using IMS Pro. So, it's important for me to get this working for the people that ask for it. I bought, installed and have been using it since 2006. I have 670 users and over 30,000 images uploaded.

TurnKey Admin

  • Administrator
  • *****
  • Posts: 63
    • View Profile
Re: IMS Pro TWO Issues
« Reply #3 on: May 06, 2010, 12:58:43 pm »
Seems like it is controlled by $user_info[max_filesize] which mean be a setting in IMS Pro.
I haven't touched IMS Pro since I took it over mainly since the code would need a lot of work to bring it up to higher quality.